Category Cryptography
Top Cryptography packages by yearly commits
Encryption, hashing, signing, and cryptographic primitives
Ranks repos by total commits over the past 52 weeks. Activity, not quality. A finished library may rank low. A thrashing one may rank high.
Packages need a public GitHub repo, at least 50 commits in the past 52 weeks, and at least 100 downloads a day. Monorepo siblings collapse to the highest-downloaded package.
stellar_flutter_sdk first shipped 6 years ago. Ranks #5 in Cryptography by commit activity, #105 by daily downloads in the same category.
| Rank | Package | Description | Commits / yr | Last commit | Downloads / day | Stars |
|---|---|---|---|---|---|---|
| #1 | 🇺🇸 atsign.org | Package for at_protocol cryptographic and hashing operations | 3.3K | 20d ago | 677 | ★ 1.4K |
| #2 | 🇸🇬 steenbakker.dev | A Flutter plugin for securely storing sensitive data using encrypted storage. | 541 | 1mo ago | 180.3K | ★ 1.3K |
| #3 | 🇪🇬 bdaya-dev.com | A library for doing cryptographic signing/verifying and encrypting/decrypting. | 537 | 11d ago | 3K | ★ 73 |
| #4 | A simple pure dart package used for creating and validating Json Web Tokens using the private and public key provided, refer to documentation for more information. | 502 | 16d ago | 186 | ★ 64 | |
| #5 | A Stellar SDK for Flutter, that can query Horizon and Soroban RPC, build, signs and submit transactions to Stellar. Supports many SEPs and can deploy and invoke Soroban Contracts. | 346 | 21d ago | 103 | ★ 88 | |
| #6 | 🇺🇸 aws-amplify.com | A Dart-only implementation of `amplify_secure_storage`, using `dart:ffi` for Desktop and `dart:html` for Web. | 342 | 20d ago | 5.7K | ★ 1.4K |
| #7 | 🇩🇪 skycoder42.de | Dart bindings for libsodium, for the Dart-VM and for the Web | 202 | 19d ago | 928 | ★ 41 |
| #8 | 🇸🇬 affinidi.com | Affinidi SSI library for Dart provides a comprehensive suite of tools and libraries for implementing Self-Sovereign Identity (SSI) solutions. | 103 | 1mo ago | 278 | ★ 8 |
| #9 | 🇩🇪 cbl-dart.dev | Flutter Plugin for Couchbase Lite, an embedded, NoSQL JSON Document Style database, supporting Blobs, Encryption, SQL++ Queries, Live Queries, Full-Text Search and Data Sync. | 99 | 22d ago | 127 | ★ 152 |
| #10 | yardenah.com | Pure Dart post-quantum cryptography. Zero dependencies. ML-KEM, ML-DSA, and SLH-DSA with checked-in NIST vector evidence. | 91 | 1mo ago | 930 | ★ 5 |
| #11 | 🇲🇹 projectcatalyst.io | A dart plugin implementing CBOR Object Signing and Encryption (RFC 9052, RFC 9053). | 89 | 8mo ago | 101 | ★ 40 |
| #12 | bitanon.dev | Pure-Dart symmetric ciphers (AES modes, ChaCha20, XChaCha20, Salsa20, XSalsa20), their Poly1305 AEAD variants, and ML-KEM post-quantum key encapsulation (FIPS 203). | 87 | 2mo ago | 151 | ★ 11 |
| #13 | Convert Ed25519 public keys between various encoding formats. | 81 | 27d ago | 113 | ★ 18 | |
| #14 | 🇺🇸 google.dev | PEM encoding/decoding of textual keys following RFC 7468, supporting both lax/strict-mode, and certificates chains of concatenated PEM blocks. | 77 | 1mo ago | 3.8K | ★ 508 |
| #15 | 🇺🇸 dart.dev | Implementations of SHA, MD5, and HMAC cryptographic functions. | 59 | 17d ago | 455.9K | ★ 74 |
| #16 | 🇺🇸 google.dev | Cross-platform implementation of Web Cryptography APIs for Dart. | 57 | 23d ago | 1.1K | ★ 115 |
